You are viewing this site as a guest. You can still ask questions and help others! Join our Dev2Dev IT Community to receive your own blog, share your knowledge, and much more.

SQR Graphics :: Unsupported grafcap Device

4 replies [Last post]
sankhara's picture
User offline. Last seen 12 years 20 weeks ago. Offline
Joined: 07/25/2008
Posts: 3

Can anyone tell me about this error occurring while printing bar graphs through SQR.

The error msg is "Unsupported grafcap device." A soln is also i seek.

Thank You.

Lepa's picture
User offline. Last seen 2 years 20 weeks ago. Offline
Joined: 06/23/2008
Posts: 591
Re: SQR Graphics :: Unsupported grafcap Device

Hi sankhara,
I always choose Application Engine over an SQR program :) - Anyway, I never had such an error but I remember reading somewhere that such an error might be related to the LIBSTI.INI. It should have a GPATH= and IPT= entries pointing to a valid SQR BINW directory. If the file is not there you can try creating it and add the two paths to it.

LIBSTI.INI is a configuration Graph-specific initialization file (copy this file to the Windows directory if it is not there already).

Give back to the community and help it grow!
* Help with unanswered forum questions and issues
* Register or login to share your knowledge at your own blog

sankhara's picture
User offline. Last seen 12 years 20 weeks ago. Offline
Joined: 07/25/2008
Posts: 3
Re: SQR Graphics :: Unsupported grafcap Device

HI LEPA,

THANX THANX A LOT ITS WORKING.

Lepa's picture
User offline. Last seen 2 years 20 weeks ago. Offline
Joined: 06/23/2008
Posts: 591
Re: SQR Graphics :: Unsupported grafcap Device

Happy to hear that! Can you share with us how you solved the problem step by step? Remember, you can always share your experience using your own blog on the site by creating an "Article" or a "Code sample" post!

Give back to the community and help it grow!
* Help with unanswered forum questions and issues
* Register or login to share your knowledge at your own blog

chayakiran's picture
chayakiran (not verified)
Re: SQR Graphics :: Unsupported grafcap Device

can someone please let me know what needs to be done if its linux machine?
libsti.ini in C:\Windows worked perfectly, but donno whats the equivalent in linux?