You are viewing this site as a guest. You can still ask questions and help others! Join our Dev2Dev IT Community to receive your own blog, share your knowledge, and much more.

Prompt table is not populating the values.

3 replies [Last post]
Guest's picture
Guest

Hello all,
I have a field in a page which has a prompt table attached to it. When I click the prompt button in the PIA, I am not able to find any values from it. But the prompt table which is an SQL view has data in the back end. And the prompt table has a Query Security record attached to it. Does it effect the prompt table in populating the results. I per my knowledge, it will filter the data based on some criteria. But if i want to give access to that particular, how can i do that thing. Does any please help me out in solving the issue.
Thanks in advance.

Ashar's picture
User offline. Last seen 5 years 1 week ago. Offline
Joined: 03/26/2008
Posts: 227
Re: Prompt table is not populating the values.

When you click on "Advanced Lookup", is there any fields which is already populated?

Nitin's picture
User offline. Last seen 5 years 44 weeks ago. Offline
Joined: 06/30/2008
Posts: 73
Re: Prompt table is not populating the values.

Make sure Key(s) fields values are available at higher level
i.e. if view is used on level1 it mus have level 0 value for the key field.

Thanks
Nitin

pstechie's picture
User offline. Last seen 11 years 43 weeks ago. Offline
Joined: 05/11/2009
Posts: 1
Re: Prompt table is not populating the values.

I think the issue is with the Query security.
harcode some value in the SQL who is having the security access for the Querry and test...If it fetches the row then that is issue.

Thanks & Regards
PStechie