You are viewing this site as a guest. You can still ask questions and help others! Join our Dev2Dev IT Community to receive your own blog, share your knowledge, and much more.

AWE - Transaction is in XREF, but not in the PS Workflow Tables

3 replies [Last post]
Guest's picture
Guest

I am new to AWE. We have a custom AWE which was created for us by a contractor and we're not supporting it.

The issue is that the transaction request is in the header table and in the XREF table. Keys populated correctly. But the thread ID from that xref table does not exist in eoaw_stepinst; consequently, not in eoaw_userinst. This particular transaction should have a step to approve, and that step is not there. On the transaction page, it says, "No Approvals Required", which should not be the case.

Although I thought that the criteria in the approval setup kicked in correctly because the XREF got populated, I still checked that piece and I do not see anything incorrect.

Has anyone experienced this? The same transaction works seamlessly with other users.

Thanks in advance.

PPlcode's picture
User offline. Last seen 3 years 3 weeks ago. Offline
Joined: 08/10/2011
Posts: 5
Re: AWE - Transaction is in XREF, but not in the PS Workflow ...

The reason behind the absence of the thread ID in the eoaw_inst and eoaw_userinst might be ,since the particular user in the userlist of the step has a admin role. So it is automatically goes to the condition in the application package which displays the message "No Approvals required".

Please recheck the userlist and try to change the user's role and redo the transaction.

Thanks
PPlcode

Guest's picture
Guest
Re: AWE - Transaction is in XREF, but not in the PS Workflow ...

I have a similar issue but what different is

My Overtime module is meant to be auto-approved as AWE setting (the checkbox), and it is working fine.
Except it is not populated into the table mentioned by the earlier post here, "EOAW_STEPINST".

Anyonde has any idea ? would be appreciated,
I figured out the past 24 hrs but no clue.

Guest's picture
Guest
Re: AWE - Transaction is in XREF, but not in the PS Workflow ...

hi ,

In AWE on the Admin approval page i am getting the message like 'No Approvals required' and in EOAW_USERINST record data is not present. Please help on it.

Thank you,
Priyanka

Post new comment

CAPTCHA
The question below is to prevent automated spam submissions.
15 + 0 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.